Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Spell check stopped working
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

yairlasri3
New Member

Israel
5 Posts

Posted - May 05 2022 :  10:44:07 AM  Show Profile  Reply with Quote
Hi,
I tried to do a spell check in my code but the button isn't responding.
How can I fix that?
Have a nice day,
Yair

feline
Whole Tomato Software

United Kingdom
17816 Posts

Posted - May 06 2022 :  06:11:28 AM  Show Profile  Reply with Quote
Which IDE and version of VA are you using?

What type of file, what file extension, does the file have where you are trying to use spell check?

zen is the art of being at one with the two'ness
Go to Top of Page

yairlasri3
New Member

Israel
5 Posts

Posted - May 06 2022 :  08:40:12 AM  Show Profile  Reply with Quote
VA_X64.dll file version 10.9.2443.0 built 2022.01.21
DevEnv.exe version 17.1.32421.90 Community
msenv.dll version 17.0.32419.317
Comctl32.dll version 6.10.22000.120
Windows 10 10.0 2009 Build 22000.613
8 processors (x86-64)
Language info: 1255, 0x40d

Platform: Project defined
Stable Includes:
C:\Program Files (x86)\Windows Kits\NETFXSDK\4.8\Include\um;
C:\Program Files (x86)\Windows Kits\10\Include\10.0.19041.0\cppwinrt;
C:\Program Files (x86)\Windows Kits\10\Include\10.0.19041.0\winrt;
C:\Program Files (x86)\Windows Kits\10\Include\10.0.19041.0\shared;
C:\Program Files (x86)\Windows Kits\10\Include\10.0.19041.0\um;
C:\Program Files (x86)\Windows Kits\10\Include\10.0.19041.0\ucrt;
C:\Program Files\Microsoft Visual Studio\2022\Community\VC\Auxiliary\VS\include;
C:\Program Files\Microsoft Visual Studio\2022\Community\VC\Tools\MSVC\14.31.31103\atlmfc\include;
C:\Program Files\Microsoft Visual Studio\2022\Community\VC\Tools\MSVC\14.31.31103\include;

Other Includes:

Stable Source Directories:
C:\Program Files (x86)\Windows Kits\10\Source\10.0.19041.0\ucrt;
C:\Program Files\Microsoft Visual Studio\2022\Community\VC\Auxiliary\VS\src;
C:\Program Files\Microsoft Visual Studio\2022\Community\VC\Tools\MSVC\14.31.31103\crt\src;
C:\Program Files\Microsoft Visual Studio\2022\Community\VC\Tools\MSVC\14.31.31103\atlmfc\src\atl;
C:\Program Files\Microsoft Visual Studio\2022\Community\VC\Tools\MSVC\14.31.31103\atlmfc\src\mfcm;
C:\Program Files\Microsoft Visual Studio\2022\Community\VC\Tools\MSVC\14.31.31103\atlmfc\src\mfc;

This helped?
I just tried to correct my comments in Visual Studio (C++ code).
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17816 Posts

Posted - May 06 2022 :  12:05:31 PM  Show Profile  Reply with Quote
Thank you, this is good to check. Everything looks normal here. Strange, this should definitely work in C++ code files.

Is VA showing its navigation fields in the file where you are trying to spell check? These are normally found at the top of the editor window and are where the Alt-M list appears from.

If you show VA Outline does it show information for the current file?

I am trying to make sure that VA is properly active in the current file, since if it isn't that would help to explain the problem.

Is the code file part of your solution, or is it in a stable include directory / external library? Again just trying to think of something that would help explain this odd behaviour.

zen is the art of being at one with the two'ness

Edited by - feline on May 06 2022 12:05:59 PM
Go to Top of Page

yairlasri3
New Member

Israel
5 Posts

Posted - May 07 2022 :  4:14:01 PM  Show Profile  Reply with Quote
The VA Outline doesn't show anything...
The file is part of the solution so I don't know what happend... It worked last week and suddenly it stoped working...
What is your Email? I want to share an image but I don't know how to do it here...
Have a nice day and thanks for helping me!
Go to Top of Page

yairlasri3
New Member

Israel
5 Posts

Posted - May 08 2022 :  07:08:44 AM  Show Profile  Reply with Quote
Now when I think about that, I upgraded my Visual Stodio from 2019 to 2022. That could change anything?
Go to Top of Page

yairlasri3
New Member

Israel
5 Posts

Posted - May 08 2022 :  07:15:58 AM  Show Profile  Reply with Quote
Well I solved the problem by upgrading the virsion of my VA.
Thanks for helping me!
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17816 Posts

Posted - May 10 2022 :  06:34:43 AM  Show Profile  Reply with Quote
If you install a new version of Visual Studio then VA won't be installed in the new version of the IDE, you will need to install VA into VS2022. But if this was what was happening you should not have had the VA toolbar showing in VS2022.

It almost sounds like VA was inactive, which would explain why various different features were not working. Thank you for the update, for anyone else who finds this, it is also possible that disabling and enabling VA in the IDE Extensions dialog would have had the same effect. Both disabling and enabling would require an IDE restart to take full effect.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2021 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000