That's the reason I wanted to rename the enumeration value using refactoring
Actually I agree that the name of the enumeration value is not the best but on the other hand what is so against naming enumeration values the same as existing classes that have nothing to do with it.
To clearify, the enumeration is used to specify how output is shown to the user:
enum DisplayOption
{
Console,
Dialog,
Both
}