Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Visual Assist
 Feature Requests
 Play well with IntelliCode extension

You must be registered to post a reply.
Click here to register.

Screensize:
UserName:
Password:
Format: BoldItalicizeUnderlineStrikethrough Align leftCenterAlign right Insert horizontal ruleUpload and insert imageInsert hyperlinkInsert email addressInsert codeInsert quoted textInsert listInsert Emoji
   
Message:

Forum code is on.
Html is off.

 
Check to subscribe to this topic.
   

T O P I C    R E V I E W
Mnemonic Posted - Aug 16 2018 : 12:32:37 PM
Hello, when the IntelliCode extension is installed, it marks best suggestions with a star. But, if VA is enabled, the star is replaced with a question mark, and what's worse, upon selection, the question mark is inserted in code.

It would be nice if VA was able to interpret the starred suggestions properly.









17   L A T E S T    R E P L I E S    (Newest First)
feline Posted - Feb 18 2019 : 10:19:58 AM
Thank you for the update. I am not quite sure why this is now fixed for you, since I was unable to reproduce the problem with the last build of VA. So it is possible just having VA updated helped. Hopefully this will stay fixed.
Mnemonic Posted - Feb 17 2019 : 03:22:26 AM
The stars render correctly in 2316. Thank you!
feline Posted - Dec 10 2018 : 06:29:15 AM
Can you please export your VA and IDE settings and send them to me:

VA Options -> Performance -> Export Settings
IDE tools menu -> Import and Export Settings -> Export selected environment settings

and also send me the console project you are working with that has the problem. I can then import the settings and try the same solution here and see if I can reproduce the problem.

This happens so reliably for you, it suggests there is a specific trigger, but I am not sure where to look for it.

Please submit the files via the form:

http://www.wholetomato.com/support/contact.asp

including this thread ID or URL in the description, so we can match it up.
Mnemonic Posted - Dec 09 2018 : 03:52:20 AM
sean: Yes, unicode characters seem to display properly everywhere in the UI:




feline: Unfortunately, same result with a fresh console project:



Do you know what unicode character exactly is the star in the list boxes? I could try adding that one to the class names, perhaps?

EDIT: Also don't worry about it too much, it's purely a cosmetic issue :) On the other hand, MS will probably push IntelliCode much further in VS2019 so more people are likely to encounter this.
feline Posted - Dec 07 2018 : 11:15:48 AM
Mnemonic, can you please try making a new, default C# console program, and see if the stars are shown correctly in listboxes after "Console." ?

I have both the IntelliCode extension and VA 2301 installed at the same time under Windows 10, with the Czech language pack installed, and the display language set to English. The Unicode characters from Sean's tests, and the stars in listboxes from ItelliCode both display correctly for me.

So since this works in a default new solution for me, I am wondering if there is something different about your files or file encoding that could be a factor.
sean Posted - Dec 06 2018 : 10:09:39 PM
You can copy the class definition in my post then decode it using this page:
http://convertstring.com/EncodeDecode/HtmlDecode
sean Posted - Dec 06 2018 : 9:45:52 PM
Well that didn't work out -- the forum software munged what I pasted.
sean Posted - Dec 06 2018 : 9:44:56 PM
Can you see if symbols with extended characters are displayed correctly in the listbox and Methods in File (alt+m) list?

Here's some sample code:
class TestUnicodeтрагед夜の
{
private:
long трагедия;
long 夜のン;

public:
long get_трагедия1() const { return трагедия; }
void set_трагедия2(long val) { трагедия = val; }
};


Are the non-ascii characters displayed properly in VA Nav Bar, VA Outline, Methods in File (alt+m) and members listbox?
Mnemonic Posted - Dec 06 2018 : 11:25:56 AM
Yes, it does.
sean Posted - Dec 04 2018 : 4:21:18 PM
If you disable VA listboxes in C#, does the default listbox still show the stars correctly?
Mnemonic Posted - Dec 04 2018 : 4:09:39 PM
Segoe UI here as well. I do have a Czech language pack installed, but Windows display language is set to US English. I tried fiddling with the regional settings, but no matter what I do, I still see squares instead of stars. Weird.
sean Posted - Dec 04 2018 : 2:12:46 PM
That's odd -- for me, it was displaying a star. What font do you have set for Statement Completion (Tools | Options | Environment | Fonts and Colors | Settings for Statement Completion)? Mine is Segoe UI.
Mnemonic Posted - Dec 04 2018 : 1:47:45 PM
Thank you!

One question, though. Is the menu supposed to look like this?



It seems it's trying to display an invalid unicode character.
sean Posted - Dec 03 2018 : 6:35:24 PM
case=118434 is fixed in build 2301
feline Posted - Sep 01 2018 : 08:48:04 AM
It depends on what you mean

In this particular situation, disabling this VA option makes sense since it fixes the conflict with the other extension.

In general, it depends on how you work, which features of VA are most important to you, and how well VA works for you. The setting is there to give you the option, to decide what best suits you.
Madsen Posted - Sep 01 2018 : 06:37:59 AM
quote:
I am seeing the same effect here. Thank you for the clear description.

case=118434

For now you can disable the below setting as a workaround:

VA Options -> Suggestions -> Enable in C#

Sorry for the inconvenience.



Why would you disable this btw? Newbie here.
accord Posted - Aug 16 2018 : 10:06:46 PM
I am seeing the same effect here. Thank you for the clear description.

case=118434

For now you can disable the below setting as a workaround:

VA Options -> Suggestions -> Enable in C#

Sorry for the inconvenience.

© 2021 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000