Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Visual Assist
 Technical Support
 VA_X_Setup2451_0.exe fails to update VS2019.

You must be registered to post a reply.
Click here to register.

Screensize:
UserName:
Password:
Format: BoldItalicizeUnderlineStrikethrough Align leftCenterAlign right Insert horizontal ruleUpload and insert imageInsert hyperlinkInsert email addressInsert codeInsert quoted textInsert listInsert Emoji
   
Message:

Forum code is on.
Html is off.

 
Check to subscribe to this topic.
   

T O P I C    R E V I E W
barto Posted - Jun 02 2022 : 07:34:56 AM
latest VS2019, VS2022. Previously VA2440 installed. VS2022 updated without problems. VS2019 reports an error, then hangs indefinitely on this screen:



Tried to uninstall VA from VS2019 Manage Extensions




however:



but, it seems it updated anyways?






9   L A T E S T    R E P L I E S    (Newest First)
feline Posted - Jun 24 2022 : 11:44:28 AM
Uninstalling VS2019 deletes your default profile, and I suspect all profiles. So it is possible that the problem was in the profile part of the install. But you would need to be moderately "destructive" to the profile to fix the problem, even assuming it was possible to fix it by trying to reset the profile.

Thank you for the update, and I am sorry you had so many problems here.
barto Posted - Jun 24 2022 : 10:04:34 AM
Repair unfortunately didn't work, had to do a uninstall/reinstall.
feline Posted - Jun 24 2022 : 10:02:41 AM
Thank you for the update. For what its worth a few other people are also seeing similar errors in the install log in %TEMP%, with CHROMEDEBUGADAPTER, and VA seems to be installed and working correctly for these users as well.

Doing a repair, rather than an uninstall and reinstall may have also fixed the problem, just in case anyone else comes across this.
barto Posted - Jun 24 2022 : 08:58:57 AM
As it seems, my VS2019 install had some problems also with other extensions. So I uninstalled and reinstalled VS2019 and now everything works again. Thanks again for your help.
feline Posted - Jun 07 2022 : 06:42:55 AM
I don't know what to make of the log message either, I am not seeing any sign of any extension in the VS2022 extension store with Chrome in its name. If VA is working well, and everything else is as it should be, I am tempted to ignore the odd log error, but obviously if you are actually having any problems or issues then these need to be looked at.
barto Posted - Jun 02 2022 : 09:11:59 AM
I never had problems updating VA, and I have VA setup.exes dating back to 2015 on this machine.. That log file message unfortunately doesn't mean anything to me.
feline Posted - Jun 02 2022 : 09:09:32 AM
Thank you for the log files. I am not seeing any errors related to VA, but several of the log files do report:

2022-06-02 12:37:32 - Unable to load extension at: C:\PROGRAM FILES (X86)\MICROSOFT VISUAL STUDIO\2019\COMMUNITY\COMMON7\IDE\COMMONEXTENSIONS\MICROSOFT\WEBCLIENT\DIAGNOSTICS\CHROMEDEBUGADAPTER\. Exception text: Microsoft.VisualStudio.ExtensionManager.InvalidExtensionManifestException: This VSIX does not apply to any product installed on this machine. The problem could be that the VSIX manifest's format is not recognized, or that the manifest has been corrupted. ---> System.InvalidOperationException: There is an error in XML document (12, 5). ---> System.Xml.Schema.XmlSchemaValidationException: The element 'Identifier' in namespace 'http://schemas.microsoft.com/developer/vsx-schema/2010' has incomplete content. List of possible elements expected: 'SupportedProducts' in namespace 'http://schemas.microsoft.com/developer/vsx-schema/2010'.

so this could be the root cause of the error messages, but I am not sure why uninstalling VA failed.
barto Posted - Jun 02 2022 : 08:52:14 AM
Yes, VA seems to work in VS2019.
Here are the install/uninstall logs from today:
https://we.tl/t-M6mkovQ09Y
feline Posted - Jun 02 2022 : 08:47:50 AM
Strange. Can you please look in your %TEMP% folder for the most recent:

vsix*.log

log files, which should cover this install, and hopefully will offer some more details.

Is VA showing up inside VS2019 and working correctly, or is it just listed as an installed extension without actually working? If you want / need to uninstall VA then loading VS2019 in safe mode should allow you to do this. You load the IDE in safe move via the command:

"C:\Program Files (x86)\Microsoft Visual Studio\2019\Community\Common7\IDE\devenv.exe" /SafeMode

© 2021 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000