Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Visual Assist
 Technical Support
 Whole Tomato causing Visual Studio to Crash?

You must be registered to post a reply.
Click here to register.

Screensize:
UserName:
Password:
Format: BoldItalicizeUnderlineStrikethrough Align leftCenterAlign right Insert horizontal ruleUpload and insert imageInsert hyperlinkInsert email addressInsert codeInsert quoted textInsert listInsert Emoji
   
Message:

Forum code is on.
Html is off.

 
Check to subscribe to this topic.
   

T O P I C    R E V I E W
karl_loveridge@yahoo.com Posted - Sep 21 2022 : 2:22:26 PM
I'm using Visual Studio 2019 v. 16.9.4. I've recently been having a lot of crashes where I'm typing a line of code and intellisense will suddenly hang. I always see the Whole Tomato extension trying to do something with suggesting code just before the crash. So the Whole Tomato extension is squarely in my sites as the culprit.

I've disabled the Whole Tomato extension. I haven't seen the crash for a while now. I'm trying to use Visual Studio for the day without it just to be sure.

My extension is up to date. Just wondering if there is something I could delete or cleanup that might fix this?
6   L A T E S T    R E P L I E S    (Newest First)
feline Posted - Sep 23 2022 : 06:01:32 AM
Thank you for the update, it sounds like there was a corruption problem with either the VA or IDE symbol database then. Hopefully this stays fixed and working well for you
karl_loveridge@yahoo.com Posted - Sep 22 2022 : 6:05:01 PM
Been using VA all day since I did the above recommendations. Haven't seen a crash yet. I'm going to say this is fixed. If it comes back I'll be sure to report it. Thanks again!
karl_loveridge@yahoo.com Posted - Sep 22 2022 : 09:08:36 AM
Just did your suggestions and will let you know how things go.
karl_loveridge@yahoo.com Posted - Sep 22 2022 : 08:32:08 AM
Haven't tried your solution yet. But to answer your questions. I am working on a custom game engine written in c++. I will give this a try and see if it resolves the issue. Thank you for your response.
feline Posted - Sep 22 2022 : 07:25:23 AM
A random follow up thought, are you working with Unreal Engine? If so, do you have the Unreal Engine extension installed? We did just get a report from one user of regular crashing with VA and the UE extension installed, but we don't have any further details on that yet.
feline Posted - Sep 22 2022 : 07:24:22 AM
To state the obvious this should not be happening, and I don't think anyone else has reported this problem.

Which programming language or languages are you working in? Corruption in the IDE intellisense database is very rare, but can happen, and can trigger crashes.

So as a first step, can you please try pressing the button:

VA Options -> Performance -> Rebuild symbol databases

which will require an IDE restart to take effect. The next step is to disable IDE intellisense via:

IDE tools menu -> Options -> Text Editor -> C/C++ -> Advanced -> Disable Database = True

but obviously this won't have much effect if you only work in C#.

If this doesn't have any effect a mini dump or two of the crash would be most appreciated. There are also further tests we can try as well.

© 2021 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000