Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
 All Forums
 Visual Assist
 Technical Support
 Settings between VS2019 and VS2019 Preview

You must be registered to post a reply.
Click here to register.

Screensize:
UserName:
Password:
Format: BoldItalicizeUnderlineStrikethrough Align leftCenterAlign right Insert horizontal ruleUpload and insert imageInsert hyperlinkInsert email addressInsert codeInsert quoted textInsert listInsert Emoji
   
Message:

Forum code is on.
Html is off.

 
Check to subscribe to this topic.
   

T O P I C    R E V I E W
Uniwares Posted - May 13 2020 : 05:13:17 AM
I have just installed the VS2019 Preview 16.6.0 preview 6
As expected all extensions are installed but disabled. When enabling VA I have not all settings migrated from VS2019 16.5.5

Especifcally the colors are not transfered. And worse, I cant change them. Changed colors are not saved.

Any idea whats going on?
2   L A T E S T    R E P L I E S    (Newest First)
feline Posted - May 14 2020 : 11:22:00 AM
Silly sounding question, but are the IDE settings themselves saving correctly?

I have seen some IDE settings apparently get shared between VS2017 and VS2019. I never really looked into it closely, so I am not sure quite what was happening there.

Another thought, if you look in the directory:

%USERPROFILE%\AppData\Local\Microsoft\VisualStudio
do you see only one profile directory for VS2019, "16.*", or is there more than one? Any you have created via the "/RootSuffix VATest" command line switch will be extra. I am wondering if the preview is sharing the same profile directory as normal VS2019, or if it is using a separate profile directory on your system. I suspect VA is sharing its settings between both versions of VS2019, since these are normally saved out to the registry, in:

HKEY_CURRENT_USER\Software\Whole Tomato\Visual Assist X\VANet16
I don't know if you know or not, but VA writes out its settings to the registry on exit, which is by design. So if you have two instances of VS2019 open at the same time that are saving to the same registry settings, which is probably the case here, the last closed instance of the IDE set's the VA settings that will be used going forward.
Uniwares Posted - May 13 2020 : 06:12:02 AM
After restarting all instances of VS (normal and preview) things seem back to normal. Although colors got mixed up in both versions and even importing the old VA settings file doesnt seem to restore all previous colors. Have to check whats up here. But something is definitely not right.

© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000