Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Build 1432 occasional lockup (cpu spins @40-50%)
 New Topic  Topic Locked
 Printer Friendly
Author Previous Topic Topic Next Topic  

chrisd
Junior Member

20 Posts

Posted - Nov 30 2005 :  12:12:17 PM  Show Profile

Occasionally when returning to Visual Studio 2003 that has been idle for a few hours the CPU starts to spin and End Process is the only solution. I have included the stack trace of the offending thread. This problem occurs 1-2 a week and when it does occur I have 2-3 instances of vs2003 running, but only the 1 instance goes bad.

ntdll.dll!KiFastSystemCallRet
USER32.dll!DispatchMessageA+0xf
va_x.dll+0x148f2
ole32.dll!ReadFmtUserTypeStg+0x4d6
ole32.dll!ReadFmtUserTypeStg+0x48c
ole32.dll!CoImpersonateClient+0x104
ole32.dll!CoWaitForMultipleHandles+0xe6
mscorwks.dll!GetCompileInfo+0x5a8da
mscorwks.dll!GetCompileInfo+0x5a865
mscorwks.dll!GetCompileInfo+0x598c8
mscorwks.dll!GetCompileInfo+0x4d5c5
mscorwks.dll!GetCompileInfo+0x4d1ee
mscorwks.dll!GetCompileInfo+0x4d124
mscorwks.dll!GetCompileInfo+0x4c090


Thanks
Chris

feline
Whole Tomato Software

United Kingdom
16914 Posts

Posted - Nov 30 2005 :  4:59:05 PM  Show Profile
do you have any other plugin's installed? i will pass this onto support, hopefully they can make something of it.

zen is the art of being at one with the two'ness
Go to Top of Page

chrisd
Junior Member

20 Posts

Posted - Dec 01 2005 :  12:37:50 PM  Show Profile
Currently whole tomato is the only plug-in I have installed. The problem only seems to happen when whole tomato is installed. Unfortunately it is not consistent, so debugging it will be a challenge to say the least. Let me know if there is anything else I can do to help solve this.

Thanks
Chris
Go to Top of Page

support
Whole Tomato Software

5566 Posts

Posted - Dec 05 2005 :  08:44:01 AM  Show Profile
Can you send the file ".../Visual Assist X/Startup.log" to Support@wholetomato.com? It should tell us which message it was processing when it crashed.
Go to Top of Page

evolution
Ketchup Master

USA
87 Posts

Posted - Dec 07 2005 :  2:29:18 PM  Show Profile
I'm having a similar problem, although (at least on my machine) it doesn't seem related to the amount of time VS.NET2003 has been open. Also, on my machine, it sometimes recovers after crunching away for 5 minutes or so. I tried capturing the callstack periodically while the devenv.exe process is seemingly locked at 100% usage, and the last node is always the same. While the stack can be varying lengths, MigrateDevColor from the va_x.dll always seems to be the last node (presumably the problem is in this function?):

ntoskrnl.exe!ExReleaseResourceLite+0x2b4
ntoskrnl.exe!IoPageRead+0x892
hal.dll!HalClearSoftwareInterrupt+0x342
va_x.dll!MigrateDevColor+0xa74d1
ntoskrnl.exe!KeUserModeCallback+0xbd
ntoskrnl.exe!KeUserModeCallback+0x87
ntoskrnl.exe!KeUserModeCallback+0xbd
va_x.dll!MigrateDevColor+0xa74d1

what could possibly go wrong? :D
Go to Top of Page

support
Whole Tomato Software

5566 Posts

Posted - Dec 08 2005 :  9:23:01 PM  Show Profile
We redirect this thread to another where hopefully, the fix is in the next build.

http://forum.wholetomato.com/forum/topic.asp?TOPIC_ID=4208
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Topic Locked
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000