Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Installer hangs
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

lex
Senior Member

34 Posts

Posted - Mar 12 2020 :  7:18:34 PM  Show Profile  Reply with Quote
The VA update (downloaded exe installer) always hangs if Visual Studio isn't closed before starting it.



There's nothing to indicate that VS can't be running while VA is updating and the installer doesn't try to close it automatically. It just says "retrying" after a while. And then it has to be killed, because clicking the close button does nothing and closing Visual Studio at this point also does nothing.

feline
Whole Tomato Software

United Kingdom
16408 Posts

Posted - Mar 13 2020 :  09:51:28 AM  Show Profile  Reply with Quote
Strange. Have you tried rebooting? I am wondering if there is another (hung) process running in the background that our installer is picking up, and thus thinks that the IDE is running, even though there is no sign of the IDE its self.

If this makes no difference, which version of the installer have you downloaded? If it is the latest version, 2366.0, then the file size should be 42,366,672 bytes. The SHA256 hash of the installer should be:

SHA256: BEAC5B6A506D57EFF301BED75308C69E14800F60978600EE483D97B598EEC1E9

you can compare these values to your installer, to see if you have a complete download.

zen is the art of being at one with the two'ness
Go to Top of Page

lex
Senior Member

34 Posts

Posted - Mar 13 2020 :  10:58:43 AM  Show Profile  Reply with Quote
This has happened for years now. So obviously not specific to this version or even this computer. It also happened with VS 2017. I was just annoyed enough to actually report it this time. But for the record: both size and sha256 is correct.

If I remember to quit VS before starting the installer it always works. No need to reboot.

If nothing else, maybe you could make the close button responsive and add some more info to the dialog? Or just refuse to start if VS is already running.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16408 Posts

Posted - Mar 13 2020 :  1:55:20 PM  Show Profile  Reply with Quote
Ah, I missed your comment about not closing the IDE first. I always close the IDE before running the installer, out of habit.

But I have just tested this. Running Windows 10 I loaded VS2019, loaded a solution, then ran the VA installer. Once I got to the message box about the installer waiting to install, I closed the IDE and left the installer running for a few minutes. When I returned to check this machine the installer had finished installing, successfully, for VS2019.

Which OS are you using?

When you see this problem, how many instances of the IDE do you have open? I would guess one, but that's just a guess.
Do you have a solution open in the IDE? I am assuming you do.
How long have you left the installer running before killing it? I am wondering if I just left it running longer than you did.

zen is the art of being at one with the two'ness
Go to Top of Page

lex
Senior Member

34 Posts

Posted - Mar 13 2020 :  7:33:12 PM  Show Profile  Reply with Quote
Windows 10.
I usually have one instance running with a solution loaded.
I can't say I've ever waited more than a minute for it to complete so that could explain it. I can test it next time and wait longer.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16408 Posts

Posted - Mar 14 2020 :  08:04:12 AM  Show Profile  Reply with Quote
Are you working with a fairly large solution? This is a very vague question, I know, but if your solution takes several seconds, or longer, to load then it will also take time for the IDE to fully exit when you close it down. During this time, the system will be busy, and the installer will still be waiting for the IDE to finish closing.

I have just re-tested this here, and launching the VA exe installer before closing VS2019 didn't delay the installer by much, but I did have to wait for the installer to notice that the IDE had been closed.

zen is the art of being at one with the two'ness
Go to Top of Page

lex
Senior Member

34 Posts

Posted - Mar 16 2020 :  6:18:19 PM  Show Profile  Reply with Quote
I only work with small cmake solutions but they still take around 10 seconds to load, without any extensions enabled. What usually happens is I quit VS and then kill the installer process after a while and restarts it right away.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16408 Posts

Posted - Mar 17 2020 :  11:22:16 AM  Show Profile  Reply with Quote
I am still not really seeing the problem here with a tiny cmake solution, but it could be the solution is to small, or I am just being a bit more patient.

How many files do you have in your solution?

If you open VA's Open File in Solution dialog (Alt-Shift-O) the title bar contains two numbers. The first number is the number of files currently listed, which changes as you filter the list. The second number is the total number of files in the list, which is normally the number of files in your solution. What is this second number?

zen is the art of being at one with the two'ness
Go to Top of Page

lex
Senior Member

34 Posts

Posted - Mar 17 2020 :  1:40:52 PM  Show Profile  Reply with Quote
I'm pretty sure I was working on a solution with only 14 source files. It was either that one or another one with 934 files, but about 90% of those are binary files that shouldn't be parsed by the IDE. The larger one takes about 20 seconds to load.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16408 Posts

Posted - Mar 18 2020 :  07:38:16 AM  Show Profile  Reply with Quote
Even with a larger CMake project, once the initial wait has passed the installer is picking up me closing VS2019 really quite quickly, without any problems at all. It does look like you just need to give the installer a bit more time if you launch it with the IDE open.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000