Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Visual Studio 2019 Preview - Open edmx file
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

bartlynn
New Member

USA
6 Posts

Posted - Jul 07 2020 :  4:34:19 PM  Show Profile  Reply with Quote
VS 2019 Version 16.7.0 Preview 3.1 (June 23, 2020)
I noticed today I get an error when I try opening a .edmx (entityframework) file. When I double click it, I get then error below. I tried version 2382, 2375, 2358, and 2353 with all the same result. When I disable Vassist, the issue goes away. It was working with the preview, maybe prior to 3.1. With older versions of Vassist, I get an invalid pointer error, but basically the same issue, can't open the edmx and show the diagram. The second screenshot shows what should be shown. I can only get that if I disable the extension in the extension manager or uninstall.










feline
Whole Tomato Software

United Kingdom
16778 Posts

Posted - Jul 08 2020 :  1:22:22 PM  Show Profile  Reply with Quote
Working on setting up a test case here, but having problems.

I have got the local SQL server working, with a copy of the Northwind Microsoft sample database loaded, and inside VS2019, in the tool window "SQL Server Object Explorer" I can see the SQL Server node, and my test database listed under it.

I also have this page:

https://www.c-sharpcorner.com/article/create-and-update-an-edmx-file-using-entity-framework-data-model-in-visual-stud/

which explains how to create an EDMX file in VS2012, which is several versions older, but at least it gives me some steps to follow.

However, after telling VS2019 to create a new C# ADO.NET Entity Data Model item, I am asked to connect to a database, so Visual Studio can build my model, since I am selecting "EF Designer from database", which seems the sensible way to approach this.

At this point I am asked to connect to the database, but I cannot get this to connect. I cannot point it at the MDF database file I have created, since this is always in use, so locked. I cannot seem to get the dialog to pick up / recognise the local SQL Server that is running, despite it being shown in the IDE in the SQL Server Object Explorer window.

What do I need to know to set about making a test case for this problem?

zen is the art of being at one with the two'ness
Go to Top of Page

bartlynn
New Member

USA
6 Posts

Posted - Jul 08 2020 :  2:19:07 PM  Show Profile  Reply with Quote
try downloading the demo project from here. https://github.com/entityframeworktutorial/EF6-DBFirst-Demo/archive/master.zip
You really need a connection to a SQL server to work with EF, but I think you can see the testing with this project.

It took a couple of times loading, closing all tabs and restarting, or just opening and closing the edmx file, but I got the error eventually.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16778 Posts

Posted - Jul 09 2020 :  09:58:11 AM  Show Profile  Reply with Quote
How easy to reproduce is the error in your normal solution? How often are you seeing it?

Have you spotted any form of pattern to how / when the error happens with the sample project? So far I am not seeing the error, but I have not spent that long opening and closing files yet.

zen is the art of being at one with the two'ness
Go to Top of Page

bartlynn
New Member

USA
6 Posts

Posted - Jul 10 2020 :  08:01:02 AM  Show Profile  Reply with Quote
For me, its fairly easy. I've tried on 2 different Preview 3.1 systems. I thought it was a interaction with CodeMaid and MZTools, but I removed them and I can reproduce the issue.

I wish there was a way to capture that Visual Studio is complaining about. I have enabled VS logging, and the only thing I saw that might have any relation is The entry
<entry>
<record>1982</record>
<time>2020/07/10 11:44:34.137</time>
<type>Warning</type>
<source>VisualStudio</source>
<description>PkgDef encountered data collision in section 'HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\16.0_371bd1c4_Config\Themes\{1ded0138-47ce-435e-84ef-9ec1f439b749}\Text Editor MEF Items (VA)' for value 'Data'</description>
</entry>
<entry>
<record>1983</record>
<time>2020/07/10 11:44:34.137</time>
<type>Warning</type>
<source>VisualStudio</source>
<description>PkgDef encountered data collision in section 'HKEY_CURRENT_USER\Software\Microsoft\VisualStudio\16.0_371bd1c4_Config\Themes\{de3dbbcd-f642-433c-8353-8f1df4370aba}\Text Editor MEF Items (VA)' for value 'Data'</description>
</entry>
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16778 Posts

Posted - Jul 13 2020 :  05:57:29 AM  Show Profile  Reply with Quote
I am still looking into this, and I will let you know as soon as I make solid and useful progress on this.

zen is the art of being at one with the two'ness
Go to Top of Page

bartlynn
New Member

USA
6 Posts

Posted - Jul 15 2020 :  07:33:04 AM  Show Profile  Reply with Quote
So far, version Version 16.7.0 Preview 4.0 of Visual Studio 2019 Preview does not have the same issue. Maybe there was some conflict or some sort, but for now Vassist seems to be fine opening the edmx files. Thanks for trying to help.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16778 Posts

Posted - Jul 15 2020 :  09:29:46 AM  Show Profile  Reply with Quote
Thank you for the update, and apologies for the problems you went through here. I am glad this is "fixed", but since I never reproduced the problem here, I am not sure what happened here.

Hopefully this will stay fixed, but obviously if this, or another problem comes up again, please do let us know and I will do my best to help.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000