Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 matching brace not added with case statement
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

amoldeshpande
Junior Member

USA
12 Posts

Posted - Jul 23 2020 :  1:36:17 PM  Show Profile  Reply with Quote
if I type:

case x:
{


VaX does not create the matching brace (I have Visual Studio automatic brace completion turned off)

Known issue ? workaround ?

feline
Whole Tomato Software

United Kingdom
16778 Posts

Posted - Jul 23 2020 :  2:07:45 PM  Show Profile  Reply with Quote
Which IDE and version of VA are you using?

Do you have the:

VA Options -> Editor -> Insert () and closing } ) ] ' "

turned On or Off? If this is turned Off can you please try turning this On and see what effect, if any, this has?

zen is the art of being at one with the two'ness
Go to Top of Page

amoldeshpande
Junior Member

USA
12 Posts

Posted - Jul 27 2020 :  2:54:14 PM  Show Profile  Reply with Quote
It is On. VS 2019 16.6.5
Visual assist 10.9.2382.0

Edited by - amoldeshpande on Jul 27 2020 2:54:58 PM
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16778 Posts

Posted - Jul 28 2020 :  07:17:46 AM  Show Profile  Reply with Quote
Does VA ever insert the closing brackets for you in your code files? Is this problem specific to case statements?

Do you see the same problem in a new, default solution, or a different cpp file? I am wondering if this is somehow file or solution specific.

zen is the art of being at one with the two'ness
Go to Top of Page

amoldeshpande
Junior Member

USA
12 Posts

Posted - Jul 28 2020 :  11:30:43 AM  Show Profile  Reply with Quote
nope, never inserts the closing brackets as far as I can tell.

I also saw it once with an inline function in a header (where it did not insert the closing brace), but I can't reproduce it right now. I'll see if I can remember/repro whenI get chance.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16778 Posts

Posted - Jul 29 2020 :  07:12:25 AM  Show Profile  Reply with Quote
Are other VA features working correctly?

If you have VA Snippets enabled, are snippets inserted correctly when typing their shortcuts?

What if you select some code and press /, * or # to surround / comment the code?

I am trying to work out if this problem is limited just to closing brackets, or is showing up in other places as well.

zen is the art of being at one with the two'ness
Go to Top of Page

amoldeshpande
Junior Member

USA
12 Posts

Posted - Jul 29 2020 :  12:39:45 PM  Show Profile  Reply with Quote
well, today everything's working fine, including the case-closing braces. I will keep an eye on it and repost here if it reappears. Of course, I have enabled/disabled VaX many times since reporting this, might even have restarted Visual Studio, so a lot has changed.

Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16778 Posts

Posted - Jul 30 2020 :  06:19:12 AM  Show Profile  Reply with Quote
Strange. It is possible that an IDE restart, or possibly a reboot paired to an IDE restart was the key here.

By its self a reboot should not matter, but if there was an IDE process left running in the background, the reboot will have cleared it out. As for the IDE restart, sometimes a restart helps make sure that VA has been fully integrated into the IDE.

Obviously if this problem, or anything else, comes up then do let us know so we can try and fix the problem for you.

zen is the art of being at one with the two'ness
Go to Top of Page

amoldeshpande
Junior Member

USA
12 Posts

Posted - Jul 30 2020 :  1:43:07 PM  Show Profile  Reply with Quote
Is there some logging I can turn on all the time and just send it to you when I see the problem ?
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
16778 Posts

Posted - Jul 31 2020 :  08:03:41 AM  Show Profile  Reply with Quote
There is logging, enabled via:

VA Options -> Performance -> Enable logging

but having it on all the time isn't that helpful, since we will end up with massive amounts of logging that probably won't relate to the problem you are seeing.

If the problem seems to be that our parser is confused by some code then it is often easier to look for patterns in the code, to see if we can see what might be triggering the problem, and work from there. For example, some problems are file specific, so we know that something, normally a syntax error, further up the file is confusing our parser.

In this case though I am not sure what was going wrong, or that logs would have helped much, unless they logged an error connecting properly to the IDE.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000