Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Find And Replace incredibly slow
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

New Member

United Kingdom
3 Posts

Posted - Sep 10 2020 :  03:28:14 AM  Show Profile  Reply with Quote
Since Microsoft replaced the Find And Replace with the new style the search has become insanely slow for me. ~30-60 seconds for a pretty small solution (~3000 LOC), although solution size doesn't seem to be all that much of a factor as another solution with ~1000+ files and a few hundred thousand lines and it takes a similar amount of time to search.

This slowness occurs when repeatedly searching for the same result or picking random words.

When disabling the Visual Assist extension however the search becomes instantaneous, I have spoken to friends and colleagues who use VS without VA and they have not observed any problems in the search much prefer the new style.

Obviously I have a workaround which is to toggle enabling/disabling VA, thankfully this can be key bound - but I figure it's worth a report.

I noticed this issue when Microsoft initially implemented the new find and replace feature, but was able to revert to the old method, they have since removed the old method entirely in 16.7.

I have tried this on 2 different machines, one a Ryzen based desktop, other an Intel based laptop. The laptop doesn't have this issue, just the desktop.

Is there anything I can do to help root cause this issue? I'm guessing I have some conflicting software installed doing something odd, so will dig into that.

Here's my current system info:

VA_X.dll file version 10.9.2389.0 built 2020.09.03
DevEnv.exe version 16.7.30503.244 Professional
msenv.dll version 16.0.30501.64
Comctl32.dll version 6.10.19041.1
Windows 10 10.0 2004 Build 19041.450
24 processors (x86-64, WOW64)
Language info: 1252, 0x809

Platform: Project defined
Stable Includes:
C:\Program Files (x86)\Windows Kits\NETFXSDK\4.8\Include\um;
C:\Program Files (x86)\Windows Kits\10\Include\10.0.18362.0\cppwinrt;
C:\Program Files (x86)\Windows Kits\10\Include\10.0.18362.0\winrt;
C:\Program Files (x86)\Windows Kits\10\Include\10.0.18362.0\shared;
C:\Program Files (x86)\Windows Kits\10\Include\10.0.18362.0\um;
C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\VC\Auxiliary\VS\UnitTest\include;
C:\Program Files (x86)\Windows Kits\10\Include\10.0.18362.0\ucrt;
C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\VC\Auxiliary\VS\include;
C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\VC\Tools\MSVC\14.27.29110\atlmfc\include;
C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\VC\Tools\MSVC\14.27.29110\include;

Other Includes:

Stable Source Directories:
C:\Program Files (x86)\Windows Kits\10\Source\10.0.18362.0\ucrt;
C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\VC\Auxiliary\VS\src;
C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\VC\Tools\MSVC\14.27.29110\crt\src;
C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\VC\Tools\MSVC\14.27.29110\atlmfc\src\atl;
C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\VC\Tools\MSVC\14.27.29110\atlmfc\src\mfcm;
C:\Program Files (x86)\Microsoft Visual Studio\2019\Professional\VC\Tools\MSVC\14.27.29110\atlmfc\src\mfc;

New Member

United Kingdom
3 Posts

Posted - Sep 10 2020 :  03:59:02 AM  Show Profile  Reply with Quote
Ok so a quick update as I did the obvious thing, completely uninstalling VS and reinstalling it seem to solve the problem!
Go to Top of Page

Whole Tomato Software

United Kingdom
17255 Posts

Posted - Sep 10 2020 :  06:21:29 AM  Show Profile  Reply with Quote
Thank you for the update, and apologies you had to do the uninstall, reinstall, but thankfully this fixed the problem for you. I am not sure what might have gone wrong here, all rather strange.

zen is the art of being at one with the two'ness
Go to Top of Page

New Member

United Kingdom
3 Posts

Posted - Sep 21 2020 :  03:31:51 AM  Show Profile  Reply with Quote
No problem, it is strange indeed! Glad to provide some public info on my solution, fortunately the VS install experience is miles better these days
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000