The members list was always helpful but at the same time never useful enough (for me at least). There are several things that I would like to see in it:
1) grouping of members with region support
2) removal of repeating namespace/classnames
Let me explain:
It would be great to group the members the same way as they are grouped/sorted in the class view. Group by access, type, name, etc. If there are regions, split the members in subgroups by regions with the same sorting as in the class view. The current, alphabetic sort is nice but not very helpful in larger or organized files, since it destroys whatever order the programmer has put the content.
The removal of repeating namespace/classnames is simply a way to make the list more readable. For example:
The list shows now
MyNameSpace.MyClass
MyNameSpace.MyClass.aPropertyX
MyNameSpace.MyClass.function1(...)
MyNameSpace.MyClass.function2(...)
MyNameSpace.MyClass.function3(...)
MyNameSpace.MyClass.function4(...)
MyNameSpace.MyClass.function5(...)
MyNameSpace.MyClass.function6(...)
MyNameSpace.MyClass.MySubClass
MyNameSpace.MyClass.MySubClass.MySubClass(int)
MyNameSpace.MyClass.MySubClass.~MySubClass()
MyNameSpace.MyClass.PropertyY
MyNameSpace.MyClass.zProperty
MyNameSpace
By putting it into the right hierarchy and removing the redundant information, it looks like that:
MyNameSpace
MyNameSpace.MyClass
.function1(...)
.function2(...)
.function3(...)
.function4(...)
.function5(...)
.function6(...)
.aPropertyX
.PropertyY
.zProperty
MyNameSpace.MyClass.MySubClass
.MySubClass(int)
.~MySubClass()
.otherProperty
And with regions:
MyNameSpace
MyNameSpace.MyClass
.function1(...)
.zProperty
#superduperregion1
.function6(...)
#whocaresaboutthose
.function3(...)
.function5(...)
#maintenancehell-dontopen
.function2(...)
.function4(...)
.aPropertyX
.PropertyY
MyNameSpace.MyClass.MySubClass
.MySubClass(int)
.~MySubClass()
.otherProperty
Maybe even color the background of the regions so they look even more grouped.
Isnt that much easier to read than the current way?