Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Completely disable Visual Studio 2019 Intellisense
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

eihero
New Member

5 Posts

Posted - Jan 23 2021 :  06:20:29 AM  Show Profile  Reply with Quote
I tried to disable Intellisense from Visual Studio 2019 Option, but it will restart every time I build the project, the bottom left background task animation shows Intellisense is running.

Are there any way to completely remove it? For example, rename a certain dll? Thanks.

Edited by - eihero on Jan 23 2021 06:36:41 AM

feline
Whole Tomato Software

United Kingdom
17191 Posts

Posted - Jan 23 2021 :  06:48:27 AM  Show Profile  Reply with Quote
How did you try to disable the IDE intellisense?

The normal method is to simply set:

IDE tools menu -> Options -> Text Editor -> C/C++ -> Advanced -> Disable Database = True

if this setting is being reset when you restart the IDE then we have a separate problem, and I would suggest a reboot, to make sure nothing is interfering with the IDE's ability to save out a change to its settings.

zen is the art of being at one with the two'ness
Go to Top of Page

eihero
New Member

5 Posts

Posted - Jan 23 2021 :  07:27:05 AM  Show Profile  Reply with Quote
I disable intellisense by setting

IDE tools menu -> Options -> Text Editor -> C/C++ -> Advanced -> Disable Intellisense = True

After I tried your method by setting "Disable Database" instead, the problem disappeared. Thank you very much!
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17191 Posts

Posted - Jan 25 2021 :  08:56:23 AM  Show Profile  Reply with Quote
I suspect that Disable Intellisense disables the IDE listboxes, but still leaves the IDE parser running in the background.

zen is the art of being at one with the two'ness
Go to Top of Page

eihero
New Member

5 Posts

Posted - Jan 25 2021 :  09:05:57 AM  Show Profile  Reply with Quote
You are probably right. Intellisense still restart... :(
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17191 Posts

Posted - Jan 25 2021 :  11:16:56 AM  Show Profile  Reply with Quote
Do you mean that after setting:

IDE tools menu -> Options -> Text Editor -> C/C++ -> Advanced -> Disable Database = True

the IDE intellisense parser still seems to be active?

If so, can you please check that this setting is still set? How many instances of the IDE do you have open?

zen is the art of being at one with the two'ness
Go to Top of Page

eihero
New Member

5 Posts

Posted - Jan 25 2021 :  12:14:44 PM  Show Profile  Reply with Quote
Yes, after setting "Disable Database = True", the IDE intellisense parser will stop, but will restart in several minutes.

The setting is still set and I open only one instance of the IDE.

In my opinion, this is completely Visual Studio's problem and has nothing to do with Visual Assist. I just don't want both parsers(Visual Studio and Visual Assist) work at the same time and hope there are some hacks, f.e. rename a certain dll to disable Intellisense?
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17191 Posts

Posted - Jan 25 2021 :  12:22:17 PM  Show Profile  Reply with Quote
I have never seen the IDE ignore this setting before. Its not uncommon for our users to disable the IDE intellisense parser, to avoid exactly this situation that you are seeing.

If you look in the directory where your solutions SLN file lives, you should see a ".vs" sub-directory. With the IDE closed can you try removing this sub-directory, then load your solution, and see if it gets recreated? I am trying to confirm that the problem is the IDE intellisense database, and not something else.

zen is the art of being at one with the two'ness
Go to Top of Page

eihero
New Member

5 Posts

Posted - Jan 25 2021 :  2:33:05 PM  Show Profile  Reply with Quote
Sir, after I deleted the .vs directory, the Intellisense did not restart anymore (at least 45 min passed and dozens project rebuild)! Thank you very much!!!!
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17191 Posts

Posted - Jan 26 2021 :  07:22:37 AM  Show Profile  Reply with Quote
Thank you for the update, I am glad this helped. I am not sure why you needed to delete this directory though, for me turning off the IDE database has always been sufficient.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2019 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000