Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Install VA_X cause VS2022 error
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

Aric
New Member

4 Posts

Posted - Jun 22 2022 :  12:18:16 AM  Show Profile  Reply with Quote
When I reinstall VS2022 17.0.32602.120, then install VS_X 2451, the VS will pop up the waring, and can't be uninstall, only can reset VS.



feline
Whole Tomato Software

United Kingdom
17816 Posts

Posted - Jun 22 2022 :  09:00:09 AM  Show Profile  Reply with Quote
This obviously should not be happening. As a first step, can you please run the command:

"C:\Program Files\Microsoft Visual Studio\2022\Professional\Common7\IDE\devenv.exe" /SafeMode

if you are not using the Professional version of VS2022 you will need to edit the path to the version you are using. This should load the IDE in safe mode, and let you go into the dialog:

IDE Extensions menu -> Manage Extensions

and disable Visual Assist. This will take an IDE restart to take full effect. Does the IDE now load normally, without any problems, with VA disabled? I would expect it to, but I don't understand what has caused this problem.

If the IDE does load correctly, can you please try going back into the dialog:

IDE Extensions menu -> Manage Extensions

and enable Visual Assist again, and again restart VS2022. Occasionally there are odd errors like this that are fixed by disabling, restarting, enabling and restarting again. So it is possible this will help.

If you still get the error message, could you please send me the ActvityLog.xml file that the message lists? Hopefully this will offer some clues as to why you are seeing this problem. Please send me the files via email:

support@wholetomato.com

including this thread ID or URL in the description, so we can match it up.

zen is the art of being at one with the two'ness
Go to Top of Page

Codeplug
Junior Member

USA
23 Posts

Posted - Jun 22 2022 :  2:56:41 PM  Show Profile  Reply with Quote
I just started getting this today as well. I would get several dialogs for "XXX package did not load correctly". I tried all the usual tricks like devenv /clearcache, /updateconfiguration, /setup, /resetuserdata, but nothing helped. I did a full repair and it was working again but with no extensions. So next I got the latest VA, 2451, and installed it - problem came back.

When things were working yesterday, I was running VA 2443. The last thing I did yesterday was an extension update that showed up in my Notifications for "MI.NET Model Builder 2022".

I've since uninstalled and re-installed VS2022 and that "MI.NET Model Builder" is back in my Notifications (but I dismissed it this time). I then reinstalled VA 2451 to VS2022 and everything is working normally. Hope this helps with a repro.

gg


VA_X64.dll file version 10.9.2451.0 built 2022.04.30
DevEnv.exe version 17.2.32616.157 Professional
msenv.dll version 17.0.32602.167
Comctl32.dll version 6.10.19041.1110
Windows 10 10.0 2009 Build 19044.1766
4 processors (x86-64)
Language info: 1252, 0x409
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
17816 Posts

Posted - Jun 23 2022 :  06:56:41 AM  Show Profile  Reply with Quote
I am seeing an extension called "ML.NET Model Builder 2022", assuming this is the one you mean, here:

https://marketplace.visualstudio.com/items?itemName=MLNET.ModelBuilder2022

no obvious options to download an older version, and it is already installed in VS2022 for me, as part of my default VS2022 install.

So far no sign of any problems here.

Do you have any other extensions installed?

It is possible this is down to a problem in your default profile, which we can test if you see this problem again, and have time to run some tests.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2021 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000