Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 A Small bug
 New Topic  Topic Locked
 Printer Friendly
Author Previous Topic Topic Next Topic  

John_H_Bergman
Tomato Guru

USA
198 Posts

Posted - Oct 11 2005 :  1:37:30 PM  Show Profile
Today, I noticed this problem, its probably been here for a long time.

1. Start with VA disabled. Close all IDEs
2. Open IDE #1, then open a project, any project.
3. Enable VA
4. Open IDE #2, then open a different project.
5. Close IDE#2
6. Look in IDE #1. VA is now disabled.

Probably working as designed, but it was certainly puzzling to me when every once in a while VA would get disabled "magically".

John H. Bergman
CTO
SiliconZone


[email protected]

To Send email, remove the .online.

feline
Whole Tomato Software

United Kingdom
18833 Posts

Posted - Oct 11 2005 :  5:04:17 PM  Show Profile
how are you disabling VA? plus which IDE and version of VA are you using?

in VS 2003 if you use the menu option

VAssistX -> Enable/Disable Visual Assist X

this setting is not "preserved". if you close and restart the IDE then VA is turned back on again. this is by design.

if i understand what you are trying to do you would need to turn off VA loading on startup in tools menu -> add-in manager.

zen is the art of being at one with the two'ness
Go to Top of Page

John_H_Bergman
Tomato Guru

USA
198 Posts

Posted - Oct 11 2005 :  6:58:38 PM  Show Profile
No, what I am saying is that in IDE #1 (VS2003), I enable it. I open IDE#2 with it disabled, and it disables it in both IDEs.

VS2003. Seems like you have cross-talk between the IDEs as far as this setting goes.

John H. Bergman
CTO
SiliconZone


[email protected]

To Send email, remove the .online.
Go to Top of Page

John_H_Bergman
Tomato Guru

USA
198 Posts

Posted - Oct 12 2005 :  2:33:33 PM  Show Profile
I am using VS2003. VA 1426.

Interesting, because the addin is enabled, but VA comes up disabled (like I chose VAssistX -> Enable/Disable Visual Assist X).

I understand about the addin manager, and that the setting is not supposed to be persisted, but there is something that is not quite right. It is also spuratic... yesterday it happened almost everytime. Today it has not happened even once.

John H. Bergman
CTO
SiliconZone


[email protected]

To Send email, remove the .online.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
18833 Posts

Posted - Oct 12 2005 :  2:34:43 PM  Show Profile
can you lead me through how you are doing this? i have just done the following:

open VS 2003 with VA 1426
got to tools menu -> add-in manager
uncheck loading VA on startup
close the IDE
load IDE (number 1), VA is disabled
load another copy of the IDE (number 2), VA is disabled here as well
i cannot enable VA in IDE number 2. i have tried VA menu -> enable / disable
i have added the enable / disable button to the VA toolbar, and this has no effect
i have gone into add-in manager and turned on VA, and this has no effect

the only thing that does work is turning run VA at startup back on in add-in manager, and then restarting IDE number 2. this gives me VA enabled in IDE number 2 while VA is still disabled in IDE number 1.

OS is winXP pro SP2

zen is the art of being at one with the two'ness
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
18833 Posts

Posted - Oct 12 2005 :  2:37:33 PM  Show Profile
cross posting strikes again

the exact order of events may be important here. when you load the IDE does it load a solution? or does it wait for you to tell it which solution to load?

if you are loading the IDE, then disabling VA via its menu, then loading a solution this would make a bit more sense, but it still does not explain what you are describing.

zen is the art of being at one with the two'ness
Go to Top of Page

Wrongway
Tomato Guru

USA
129 Posts

Posted - Oct 13 2005 :  11:34:04 AM  Show Profile
How I do mine. Load VS.NET 2003 then load the solution. It seems to be enabled most of the time when I load a C# project, but when I load a C++ project (with over 102 projects) it is disabled. I just did this with the results:

Open VS.NET 2003
Loaded C# solution (with 15 projects) - OK
Closed solution
Loaded C++ solution (with 101 C++ projects and 1 C#) - Disabled

Hope this helps track it down.

Wrongway
Go to Top of Page

John_H_Bergman
Tomato Guru

USA
198 Posts

Posted - Oct 13 2005 :  1:36:52 PM  Show Profile
My solution is mixed as well, 3 C++ and 55 C# projects.

Feline, I never visit the add-in manager (other than to take a screen shot for support). The order is what was posted at the top of the Thread.

Out of curiosity, is there a key-binding that is linked to the VA enable/disable menu option?

John H. Bergman
CTO
SiliconZone


[email protected]

To Send email, remove the .online.
Go to Top of Page

John_H_Bergman
Tomato Guru

USA
198 Posts

Posted - Oct 13 2005 :  1:48:53 PM  Show Profile
One more thing... I have a 100% duplication path at the moment.. I just send support a set of steps with the screen shots, this should be enough to duplicate the problem on your side....

John H. Bergman
CTO
SiliconZone


[email protected]

To Send email, remove the .online.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
18833 Posts

Posted - Oct 13 2005 :  3:11:09 PM  Show Profile
have either of tried rebuilding the symbol databased and clearing the cache?

VA options -> performance -> general

a few builds ago i was having exactly the same problem. load a C# or VB project in VS 2003 and VA was enabled. yet load a C++ project and VA would disable its self. i checked, and VA was enabled when i loaded the IDE, before i loaded a solution.

the best theory we have at the moment is that VA's databases are corrupt, but the warning message is not displaying correctly. if the databases are corrupt what (i believe) should happen is you are informed about the problem, and then VA disables its self.

for me this problem was 100% reproducible, but only effected one test machine. a second, nearly identical machine with the same version of VA was fine. after rebuilding and (i think) reinstalling the same version of VA the problem went away.

has this been happening for more than one version of VA for either of you?

zen is the art of being at one with the two'ness
Go to Top of Page

John_H_Bergman
Tomato Guru

USA
198 Posts

Posted - Oct 16 2005 :  7:46:54 PM  Show Profile
I have seen it for several versions of VA, and for several different projects. I'll clear VA's database and see what happens.

John H. Bergman
CTO
SiliconZone


[email protected]

To Send email, remove the .online.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
18833 Posts

Posted - Oct 17 2005 :  3:16:16 PM  Show Profile
for me a combination of a rebuild and a reinstall of the same version fixed this. i am hoping this will also work for you.

zen is the art of being at one with the two'ness
Go to Top of Page

mbobka
Ketchup Master

Russia
86 Posts

Posted - Oct 18 2005 :  02:24:58 AM  Show Profile
Today, I also seen this problem. I've opened in VS.NET 2003 two projects, VA was enabled, and I don't disable it in any IDE window. First project was C# project --- VA works in it, but when I open C++ project VA disables in it, and I can't to enable it. I was try to reopen C++ project in other IDE, but VA still be disabled in it. Also VA-toolbar also was disabled, and I can't enable it by clicknig on toolbar.
Go to Top of Page

John_H_Bergman
Tomato Guru

USA
198 Posts

Posted - Oct 18 2005 :  4:42:33 PM  Show Profile
I uninstalled, rebooted, and installed VAX. Then, After a rebuild of the database I still see the same behavior.

John H. Bergman
CTO
SiliconZone


[email protected]

To Send email, remove the .online.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
18833 Posts

Posted - Oct 18 2005 :  5:08:19 PM  Show Profile
are you able to re-enable VA with the enable / disable option on the VA menu? you can also add the enable / disable button to the VA toolbar by right clicking on it and selecting customize.

zen is the art of being at one with the two'ness
Go to Top of Page

John_H_Bergman
Tomato Guru

USA
198 Posts

Posted - Oct 19 2005 :  2:52:40 PM  Show Profile
Yes, on the menu, I am able to enable/disable the option.

John H. Bergman
CTO
SiliconZone


[email protected]

To Send email, remove the .online.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
18833 Posts

Posted - Oct 19 2005 :  4:50:57 PM  Show Profile
can you try 1428 and see if that helps?

http://forum.wholetomato.com/forum/topic.asp?TOPIC_ID=4079

zen is the art of being at one with the two'ness
Go to Top of Page

John_H_Bergman
Tomato Guru

USA
198 Posts

Posted - Oct 20 2005 :  5:29:59 PM  Show Profile
Still happens with 1428

John H. Bergman
CTO
SiliconZone


[email protected]

To Send email, remove the .online.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
18833 Posts

Posted - Oct 22 2005 :  11:54:58 AM  Show Profile
i will email support. to be honest i am out of good ideas.

zen is the art of being at one with the two'ness
Go to Top of Page

support
Whole Tomato Software

5566 Posts

Posted - Oct 22 2005 :  1:50:48 PM  Show Profile
John:
What exactly are you trying to do? Have VA X run in some instances of the IDE and not in others? Load VA X after opening projects only when you want to use it?

FWIW: The add-in interfaces of the IDE are not perfect -- little is multi-threaded, add-ins often conflict, and the IDEs are not fond of loading and unloading.
Go to Top of Page

John_H_Bergman
Tomato Guru

USA
198 Posts

Posted - Oct 23 2005 :  8:07:55 PM  Show Profile
I am just looking for VA to stay enabled after I enable it. It seems that opening the 2nd IDE that appears to disable VA when I open a project also disables it in the rest of the IDEs.

John H. Bergman
CTO
SiliconZone


[email protected]

To Send email, remove the .online.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
18833 Posts

Posted - Oct 25 2005 :  6:21:40 PM  Show Profile
all right, going back and re-reading the original post here, and entering grasping at straws mode.

it is your phrase "1. Start with VA disabled." that is making people wonder what you are doing. i keep getting this idea that you are trying to run with VA enabled in some projects and disabled in other projects.

putting that to one side for the moment, you said "2. Open IDE #1, then open a project, any project."

if you have two newly created projects, to which you have done nothing, can you reproduce this? i am hoping to remove as many variables as possible, since this is either something about your machine / config, or we are all missing some key step.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Topic Locked
 Printer Friendly
Jump To:
© 2023 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000