Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 Most buttons greyed out
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

jkmgs
Junior Member

Austria
15 Posts

Posted - Sep 15 2023 :  04:53:31 AM  Show Profile  Reply with Quote
Hi there,

Currently, my Visual Assist decides to go into greyed-out mode most of the time. Sometimes at the end of day it starts working again, but most often it does not. Most of the buttons inside Visual Studio are not clickable as they are deactivated. Just some buttons under "Debug", "Tools", and "Code Inspections" are still clickable. Even the "Help" - "About Visual Assist" is greyed-out. It's not usable like that. Any ideas how to fix that?

All the best,
Johannes

feline
Whole Tomato Software

United Kingdom
18749 Posts

Posted - Sep 15 2023 :  06:29:23 AM  Show Profile  Reply with Quote
If you close and reload Visual Studio do you get any message boxes from Visual Assist? It sounds like Visual Assist is disabled. But if this was happening due to a license problem then you should be getting a message explaining that this is what is happening, and normally this happens when you load the IDE.

Is VA active in the editor window? Are you seeing any VA syntax colouring? Does Alt-G or Alt-Shift-Q do anything when triggered on a class or function?

zen is the art of being at one with the two'ness
Go to Top of Page

jkmgs
Junior Member

Austria
15 Posts

Posted - Sep 15 2023 :  09:01:57 AM  Show Profile  Reply with Quote
I don't get any message box from Visual Assist. I did not get any message box stating any license problem. It worked yesterday for a short amount of time, till I restarted Visual Studio again. Then it stopped working completely again. No, it's not active. The Go To Button is also missing when it's not active.

Edit: I figured it out. My anti-virus program switched automatically to a new software that comes as part of my backup software. I never agreed to switch and wasn't aware that was changed therefore. I made sure it is now deactivated for good. But would be helpful to get a message or similar warning from Visual Assist. Currently, it is just a trial and error till one is able to figure out what the problem is.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
18749 Posts

Posted - Sep 15 2023 :  10:12:07 AM  Show Profile  Reply with Quote
Are you using Acronis Anti-virus? We have had one report of Acronis True Image having bundled anti-virus causing problems, even though virus total says Acronis isn't reporting any problems with VA.

If not Acronis then which anti-virus are you using?

Which version of VA?

Are you able to get a report from the anti-virus to tell you which file or files inside VA it is blocking?

We may not be able to warn you, if we are being disabled directly by the anti-virus.

zen is the art of being at one with the two'ness
Go to Top of Page

jkmgs
Junior Member

Austria
15 Posts

Posted - Sep 18 2023 :  03:38:09 AM  Show Profile  Reply with Quote
Yes, I had an older version of Acronis anti-virus installed as part of a backup solution, but had the anti-virus part deactivated for the longest time, until it suddenly activated itself sometime last month for whatever reason. I uninstalled it now though while updating to the latest version of the backup solution and currently have no time to reinstall the anti-virus and test it. So I currently can't help you any further here unfortunately.
I am using VA version 2023.4.

I understand. As a user it's just also really hard to tell why it's not working. But good that you have that on your map now so you can tell other customers experiencing the same symptoms to look for any running anti-virus software too.

Edited by - jkmgs on Sep 18 2023 05:50:13 AM
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
18749 Posts

Posted - Sep 18 2023 :  05:40:58 AM  Show Profile  Reply with Quote
Thank you for the update, it is good to know you have found a solution for this. I have tried to reproduce the problem here, but so far no luck in reproducing it.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2023 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000