Whole Tomato Software Forums
Whole Tomato Software Forums
Main Site | Profile | Register | Active Topics | Members | Search | FAQ
User name:
Password:
Save Password
Forgot your password?

 All Forums
 Visual Assist
 Technical Support
 "Do not parse files" doesn't do anything
 New Topic  Reply to Topic
 Printer Friendly
Author Previous Topic Topic Next Topic  

mark99
New Member

United Kingdom
3 Posts

Posted - Feb 09 2023 :  09:21:20 AM  Show Profile  Reply with Quote
I have checked "Do not parse files excluded by .vscode\settings.json" option.

settings.json looks like this:

{
    "C_Cpp.default.compileCommands": "${workspaceFolder}/out/build/${command:cmake.activeBuildPresetName}/compile_commands.json",
    "evenBetterToml.taplo.configFile.path": ".vscode/taplo.toml",
    "files.exclude": {
        "**/out": true,
        "**/vcpkg/downloads": true,
        "**/vcpkg/packages ": true
    }
}


However VA goes ahead and parses these directories anyway, you can see it traversing those dirs in the taskbar on a symbol rebuild, plus I see ~15 definitions of everything in the various packages due to the multiple copies (which is one of the problems I'm ultimately trying to solve).

Is this feature not functioning correctly or am I mis-using it somehow? Thx.

feline
Whole Tomato Software

United Kingdom
18755 Posts

Posted - Feb 09 2023 :  12:44:44 PM  Show Profile  Reply with Quote
Which IDE and version of VA are you using? Assuming you are opening a folder, and not a solution, this is supposed to work. I am running some tests here now.

zen is the art of being at one with the two'ness
Go to Top of Page

mark99
New Member

United Kingdom
3 Posts

Posted - Feb 10 2023 :  07:52:47 AM  Show Profile  Reply with Quote

VA_X64.dll file version 10.9.2476.0 built 2023.01.19
DevEnv.exe version 17.4.33213.308 Professional
msenv.dll version 17.0.33213.231
Comctl32.dll version 6.10.19041.1110
Windows 10 10.0 21H2 Build 19044.1288 
8 processors (x86-64)
Language info: 1252, 0x809
Platform: Win32


Yes it's a cmake project rather than .sln.
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
18755 Posts

Posted - Feb 15 2023 :  10:41:35 AM  Show Profile  Reply with Quote
Apologies for the slow reply. On the last filter line in your file, can you remove the space after "packages" and before the closing double quote. This fixes the problem, after an IDE restart, for me, with your settings.json file.

I don't know if the space there matters, but it is tripping up our exclude filtering. With this space present, none of the matching directories are being excluded in my tests.

zen is the art of being at one with the two'ness
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
18755 Posts

Posted - Feb 15 2023 :  12:42:04 PM  Show Profile  Reply with Quote
case=144472

zen is the art of being at one with the two'ness
Go to Top of Page

mark99
New Member

United Kingdom
3 Posts

Posted - Feb 16 2023 :  09:41:55 AM  Show Profile  Reply with Quote
That does seem to have helped - odd that it caused all filter lines to fail and not just that 1 entry.
I still see `out` being touched in the "VA: Parsing..." status bar, however I'm now getting unambiguous symbols in the database, so seems to have worked - thanks :)
Go to Top of Page

feline
Whole Tomato Software

United Kingdom
18755 Posts

Posted - Feb 17 2023 :  06:52:26 AM  Show Profile  Reply with Quote
Thank you for the update, I am glad this has worked for you. It worked here, but I didn't want to assume that you had posted your full settings.json file, so I was half prepared to learn that this hadn't actually worked

I have put in the bug report for the space not being handled.

zen is the art of being at one with the two'ness
Go to Top of Page
  Previous Topic Topic Next Topic  
 New Topic  Reply to Topic
 Printer Friendly
Jump To:
© 2023 Whole Tomato Software, LLC Go To Top Of Page
Snitz Forums 2000